[CentOS] 3Com 3c940 moel only giving me 100 mb throughput to network switch

Gilbert Sebenste sebenste at weather.admin.niu.edu
Mon Nov 23 19:18:49 UTC 2009

On Mon, 23 Nov 2009, Les Mikesell wrote:

> I'd expect that to mean that it was connected to a 100Mb switch port or
> a managed switch configured to force 100Mb.

Managed switch, yes.

>> But then I tried this. Typing:
>> ethtool --change eth0 speed 1000 duplex full autoneg on
>> DID work! But I wonder why it didn't pick up on that automagically.
> But then that wouldn't have worked either.

Hmmm. Why not? It did on my other servers.

> Mii-tool does some of the same things but won't show/force 1000BaseT.
> Also, you can put ETHTOOL_OPTS=... in your ifcfg-eth? files if you need
> to force something odd.

Great! Thanks for the tips. Take care.

Gilbert Sebenste                                                     ********
(My opinions only!)                                                  ******

More information about the CentOS mailing list