[CentOS] rndc start fails with "rndc: connect failed: connection refused"

Tariq Ismail Dalvi tariqdalvi at gmail.com
Wed Nov 25 23:21:22 UTC 2009

Hello ,

I am facing same problem but with CentOS 5.4 and BIND 9.3.6 while I
was having 5.3 named was working fine but now it give me same error in
Service configuration panel to start named I have to reboot the system
but if I give Service named restart it stops and fails to start only I
can use service named reload on command line.

I did everything so far but no luck I shall try to go back to CentOS 5.3
thats the option I feel might work for me.


On Wed, Nov 25, 2009 at 6:04 PM, Hugh E Cruickshank <hugh at forsoft.com> wrote:
> CentOS 4.8, BIND 9.2.4
> Hi All:
> I have a rather annoying problem with rndc which I have not been able
> to resolve despite much searching and many attempts to correct. When
> making changes to our DNS entries I have tried to use the following
> procedures:
> 1. Flush the cache buffers:
>   rndc flush
> 2. Stop named:
>   rndc stop
> 3. Delete the journal files:
>   rm *.jnl
> 4. Edit the forward and/or reverse zone files as necessary.
> 5. Restart named:
>   rndc start
> Everything works fine until the last command which fails with:
>   rndc: connect failed: connection refused
> I can get around this by using "service named start" but I should not
> have to do this. Has anyone encountered something similar and can pass
> on some words of wisdom?
> Regards, Hugh
> --
> Hugh E Cruickshank, Forward Software, www.forward-software.com
> _______________________________________________
> CentOS mailing list
> CentOS at centos.org
> http://lists.centos.org/mailman/listinfo/centos

Best Regards
Tariq Ismail Dalvi
tariq at dalvis.net

More information about the CentOS mailing list