[CentOS] CentOS 5 and DRPM

Janez Kosmrlj postnalista at googlemail.com
Fri Nov 27 10:14:49 UTC 2009

OK I figgured out the client part. But unfortunately this was the easy part.
I still can't figure out, what i'm doing wrong on the server.
I tried installing deltarpm package from epel and the newest createrepo
package from atrpms (deltarpm from here won't install because it is build
against a newer rpm package and I don't like to change the rpm package on my
But when i run:* createrepo --database  --deltas  -s sha --oldpackagedirs
/dir /dir* i get some obscure python errors, that I can't figure out.

I tried the same commandon on an fedora 11 machine wiht the default fedora
packages installed and it works without problems. As far as i can see the
versions of createrepo on fedora and centos (the atrpms package) are the
same. the only different part is the python version, but that shouldn't be
the problem, since I looked at the .spec file from createrepo and it only
requires python 2.1 and centos has 2.4.

Does someone have a newer createrepo rpm package, that works on centos?


On Thu, Nov 26, 2009 at 6:38 AM, Janez Kosmrlj
<postnalista at googlemail.com>wrote:

> Do you have some manual or howto you used to do it? Like i said, there is
> wery litle info on the web, how to do it.
> On Wed, Nov 25, 2009 at 3:06 PM, Farkas Levente <lfarkas at lfarkas.org>wrote:
>> On 11/25/2009 01:00 PM, Janez Kosmrlj wrote:
>> > Has anybody successfully implemented DRPMs on centos 5.x?
>> > I searched the net and I found a few indications that it is possible,
>> > but there is very little info how to do it.
>> >
>> > Just to be clear. With DRPMs i mean deltaRPMs. And with implementation i
>> > mean What yum plugins are necessary and what has to be done on the yum
>> > repository to make it work.
>> yes i do. yum-presto and deltarpm are easy but you've to build a custom
>> createrepo packages.
>> --
>>  Levente                               "Si vis pacem para bellum!"
>> _______________________________________________
>> CentOS mailing list
>> CentOS at centos.org
>> http://lists.centos.org/mailman/listinfo/centos
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.centos.org/pipermail/centos/attachments/20091127/5e45a627/attachment.html>

More information about the CentOS mailing list