[CentOS] xen guest system - install source - NOT

Jussi Hirvi listmember at greenspot.fi
Thu Oct 8 14:00:58 UTC 2009

On 8.10.2009 16:14, Jussi Hirvi wrote:
>> On Thu, Oct 08, 2009 at 01:54:47PM +0300, Jussi Hirvi wrote:
>>>> On Oct 8, 2009, at 7:19 AM, Jussi Hirvi wrote:
>>>>> I am installing my first xen system (CentOS 5.3). The host system
>>>>>  seems to be ok.
>>>>> I am following this tutorial: 
>>>>> http://www.howtoforge.com/installing-xen-on-centos-5.2-i386-p2
>>>>> Now I try to use virt-install to install the first guest system,
>>>>> but I cannot find a working install source.
>>>>> I have tried at least these:
>>>>> http://ftp.funet.fi/pub/mirrors/centos.org/5.3/isos/i386/
>>>>> http://ftp.funet.fi/pub/mirrors/centos.org/5.3/isos/i386/CentOS-5.3-i386-netinstall.iso
>>>>> Always I get "Could not find an installable distribution".
>>>>> What should I use as path?
>>> On 8.10.2009 13:28, Giovanni P. Tirloni wrote:
>>>> It's not looking for ISOs. Try this:
>>>> http://ftp.funet.fi/pub/mirrors/centos.org/5.3/os/i386/
>>>> -Giovanni
>>> Thanks, that seems to work. (Funny, I thought I had tried that already.)
>>> Now I get another odd error, though (though maybe temporary):
>>>> ValueError: Invalid URL location given:
>>>> http://ftp.funet.fi/pub/mirrors/centos.org/5.3/os/i386/images/xen/vmlinuz
>>>> [Errno 14] HTTP Error 503: Service Temporarily Unavailable
>>> ...though I can start downloading that file manually in the browser 
>>> quite ok.
>>> Anyway, I will try that path again another time, let's see.
> On 8.10.2009 15:22, Pasi Kärkkäinen wrote:
>> Try using ftp:// instead.
>> I think funet is using some fancy http error pages that confuse
>> anaconda.
>> -- Pasi

Hm, not so simple. Now I got the installation (with program 
virt-install) to begin, but then I would see a dialog screen asking for 
ftp server, and path containing OS for my architecture. I gave for 
example the following two values:
(the latter with and without slashes at beginning and end),
but always I get the same dialog screen back after a couple of minutes 
of blank screen. No error messages.

So I am baffled again. Has someone been here before?

- Jussi Hirvi

More information about the CentOS mailing list