[CentOS] Possible to run iscsi-target and initiator on same server?

Ross Walker rswwalker at gmail.com
Sun Oct 11 21:51:29 UTC 2009

On Oct 11, 2009, at 5:14 PM, C Linus Hicks <linush at verizon.net> wrote:

> On Sun, 2009-10-11 at 15:13 -0400, C Linus Hicks wrote:
>> There's no VIF on loopback. The machine running iet has two NICs, the
>> private interconnect should not be playing a role. It's IP address is
>> while the local subnet is and the iet
>> machine is IP address
>> From running strace on the iscsid daemon, it appears to be taking  
>> what
> looks to me like an unexpected error. In the text below, look for the
> first series of "poll" system calls. Just after that section is  
> where I
> initiate the iscsiadm login command. Then about 100 lines later on, it
> issues a connect call that returns "-1 EINPROGRESS (Operation now in
> progress)". Then it goes back to polling, this time on two sockets
> including the one it just tried to connect on. In a little while it
> probably reaches the retry limit and closes that socket. It makes
> another connect attempt that fails with the same error. There are a
> total of five connect attempts, but I have cut out some of the  
> repeated
> text.

I don't know much about open-iscsi, just IET and the best way to  
diagnose iSCSI problems is via tcpdump and wireshark not strace.

Is the iscsi-target service running?


More information about the CentOS mailing list