[CentOS] yum hangs, rpm hangs (was: Re: can't remove package)

ken gebser at mousecar.com
Tue Oct 27 08:25:50 UTC 2009

On 10/27/2009 03:58 AM ken wrote:
> On 10/26/2009 05:44 AM ken wrote:
>> Just upgraded CentOS to (uname) "Linux 2.6.18-164.2.1.el5.plus #1 SMP
>> Fri Oct 9 12:34:43 EDT 2009 i686 i686 i386 GNU/Linux" and since then,
>> when emacs (version 21.4.1) starts up (using emacs -Q), where there
>> should be text there are only little empty boxes, each the size of
>> character.  The error message reads:
>> Warning: Cannot convert string
>> "-*-courier-medium-r-*-*-*-120-*-*-*-*-iso8859-*" to type FontStruct
>> Warning: Cannot convert string
>> "-*-helvetica-medium-r-*--*-120-*-*-*-*-iso8859-1" to type FontStruct
>> I've tried running "emacs --font <font-spec>" with different font specs,
>> but all of them error'd out also.
>> "fc-list" shows 156 fonts available... you'd think emacs would be able
>> to grab one of them and be happy with it.
>> What's emacs doing or trying to do?
>> Anybody have a 5.4 issue with fonts?
>> tia for any help.
> Thanks for the assistance.  :P  I couldn't solve the problem, so I
> solved the problem by reviving an emacs 23.1.1 that I compiled myself
> some months back.  And after all the diddling I did with the Fontconfig
> subsystem, the fonts I'm seeing now are much more pleasant than what I
> was getting with it before.  So it (the 23.1.1 version) must be using
> the newer font subsystem while the 21.4.1 version (installed via yum
> with the 5.4 upgrade) is using the core X stuff (which I haven't yet dug
> into).  If anyone can disagree, how does one come to know?
> One other point of weirdness: when I did "rpm -e emacs" (twice), it hung
> (didn't do anything and didn't give me back the bash prompt until I
> killed it (-9).  The same thing happens when I use "yum remove emacs".
> Why should it be impossible to remove a package?

Hmm. Now I find that *any* rpm or yum command I type in will hang.  This
is not good.

More information about the CentOS mailing list