[CentOS] question about mounting external USB HD

Ivan Arteaga iarteaga at cwpanama.net
Thu Oct 29 05:39:17 UTC 2009

John R Pierce wrote:
> Ivan Arteaga wrote:
>> Hello,
>> I have a server running CentOS 4.7 and I want to add a new USB-HD for 
>> backup some data. I made the file system as ext3 with the command:
>> /
>> mkfs -t ext3 /dev/sdb1/
>> After that I did add a new Volume Group and Logical Volume 
>> (/VolGrup01-LogVol01) /on that file system and mounted it as /backup. It 
>> worked fine but when I did reboot the server It wont mount /backup and I 
>> got the following error even after the system boots and I try to mount 
>> it manually:
>> /mount: special device /dev/VolGrup01/LogVol01 does not exist/
>> I will appreciate any comment or suggestion about the best way to get 
>> through this.
> I would *NOT* use LVM on a removable external drive.
> if you did a mkfs /dev/sdb1, you should
>     # mount /dev/sdb1 /backup
> and skip LVM entirely.
> _______________________________________________
> CentOS mailing list
> CentOS at centos.org
> http://lists.centos.org/mailman/listinfo/centos
> ------------------------------------------------------------------------

I did remove the LVM and mounted the file system i had in /dev/sdb1 as 
/backup, It works now...

[root at server]# mount /dev/sdb1 /backup
[root at mail ~]# df -kh
Filesystem            Size  Used Avail Use% Mounted on
/dev/sdb1             459G  105M  436G   1% /backup
[root at server]#

I cant restart the server now but I will have a maintenance window 
tomorrow so I will check after the reboot how it goes... I added it to 
/etc/fstab anyway:

//dev/sdb1  /backup  ext3  suid,dev,exec  0  0/

Thanks in advance for your suggestion.


More information about the CentOS mailing list