[CentOS] Problem YUM Centos 5

m.roth at 5-cent.us m.roth at 5-cent.us
Fri Oct 30 21:35:23 UTC 2009

Dianne wrote:
> On Oct 30, 2009, at 8:43 AM, Adriano Frare wrote:
>> Today , I ran command yum update and  I received follow error below.
>> ======================= BEGIN =========
>> Loaded plugins: fastestmirror
>> Determining fastest mirrors
>> Traceback (most recent call last):
>>  File "/usr/bin/yum", line 29, in ?
>>    yummain.user_main(sys.argv[1:], exit_code=True)
>>  File "/usr/share/yum-cli/yummain.py", line 229, in user_main
>>    errcode = main(args)
>> <snip>
> Whenever yum gets weird I usually run "yum clean all" and everything
> gets better.  CentOS 5.4 is out so if you haven't upgraded yet, check
> the release notes before running your next "yum update."

I literally figured that out yesterday - I'm rolling out the 5.3->5.4
upgrades. One thing though - on some servers that still had 5.2, yum
crashed on sfpio<whatever> I then did yum update yum, and it stopped
dying; though it still failed. *Then* I did yum clean all, and then yum -y
update worked like a charm.

Wish there was a  way to tell yum "answer q (rpm default action) to all


More information about the CentOS mailing list