[CentOS] Problem updating VM

Mon Apr 5 19:53:29 UTC 2010
Chris Geldenhuis <chris.gelden at iafrica.com>


I am trying to bring one of my CentOS 5 VMs up to date.

I have run:

yum clean all

yum update yum

yum clean all

yum update python* rpm*

yum clean all

without any problems or error messages.

Now when I try to run yum update, I get the following:
[root at tusker ~]# yum update
There was a problem importing one of the Python modules
required to run yum. The error leading to this problem was:

   No module named cElementTree

Please install a package which provides this module, or
verify that the module is installed correctly.

It's possible that the above module doesn't match the
current version of Python, which is:
2.4.3 (#1, Sep  3 2009, 15:37:37)
[GCC 4.1.2 20080704 (Red Hat 4.1.2-46)]

If you cannot solve this problem yourself, please go to
the yum faq at:

I then downloaded the python-clementtree package from dags site and 
tried to install it and get:

[root at tusker ~]# rpm -i ./python-celementtree-1.0.5-1.2.el5.rf.x86_64.rpm
warning: ./python-celementtree-1.0.5-1.2.el5.rf.x86_64.rpm: Header V3 
DSA signature: NOKEY, key ID 6b8d79e6
error: Failed dependencies:
        python-elementtree conflicts with 

yet when I query the package I get:

[root at tusker ~]# rpm -q python-celementtree-1.0.5-1.2.el5.rf.x86_64.rpm
package python-celementtree-1.0.5-1.2.el5.rf.x86_64.rpm is not installed

and when I try to remove it I get:

[root at tusker ~]# rpm -e ./python-celementtree-1.0.5-1.2.el5.rf.i386.rpm
error: package ./python-celementtree-1.0.5-1.2.el5.rf.i386.rpm is not 

I have tried rebuilding the rpm database with no result.

Any suggestions?