[CentOS] memory leak observed with valgrind on CentOS release 5.4 (Final)

Fri Apr 16 04:20:53 UTC 2010
Jai Prakash <jprakash at dgit.biz>

Hi All,


Not sure exactly a memory leak or not. I was porting my nagios from
Redhat 7.3 to CentOS 5.4 and I observed the memory usage was gradually
increasing on the new centos box. 


When I ran all my perl plugins with Valgrind -3.2.1, all the plugins
complained about a memory leak. Not sure if it's a leak or if its fault
with valgrind way of evaluating things. 


I have attached valgrind output when i ran a simple hello-world.pl on my
centos box.  


I shall greatly appreciate if anyone have faced similar behaviour.



Jai Prakash



-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.centos.org/pipermail/centos/attachments/20100416/d579aa8a/attachment-0004.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: perl-leak.26127
Type: application/octet-stream
Size: 8484 bytes
Desc: perl-leak.26127
URL: <http://lists.centos.org/pipermail/centos/attachments/20100416/d579aa8a/attachment-0004.obj>