[CentOS] Cobbler import files with rsync error

Sat Apr 10 05:45:11 UTC 2010
Rudi Ahlers <rudiahlers at gmail.com>

On Sat, Apr 10, 2010 at 2:07 AM, Joseph L. Casale
<jcasale at activenetwerx.com> wrote:
>>I'm trying to import in image into Cobbler (working with this:
>>https://fedorahosted.org/cobbler/wiki/UsingCobblerImport) but keep on
>>getting the following error:
>>total size is 322467472  speedup is 1.00
>>rsync error: some files/attrs were not transferred (see previous
>>errors) (code 23) at main.c(1042) [sender=3.0.7]
>>Command failed
> /snip
>>[root at intranet ~]# cobbler import --path=/mnt/dvd --name="Openfiler 2.3"
> Don't know sfa about cobbler, but exit value 23 is rather vague, it can
> occur with all sorts of causes like permissions/attrs etc. Proly manifesting
> in the case of the iso being the source?
> Not having cobbler installed, what is the exact rsync command used?
> Maybe ps while an import is running if you can't find it? It might need
> a modification... My guess is it's all there, but the non zero return
> it traps puts the kybosh on the import being accepted.
> _______________________________________________

Yes, that makes it rather difficult to try and find out what's wrong.

google also suggested it could be a permissions problem, but I mounted
the ISO as root and imported it as root. The Cobbler tutorials I have
found doesn't mention anything about mounting the ISO's in any special
way, so I got no idea how doto it differently.

I just ran rsync manually and it worked fine, as follows:

[root at intranet ~]# rsync -avp --progress /mnt/dvd/*
/var/www/cobbler/ks_mirror/Openfiler\ 2.3/

-------- SNIP -------------
       46253 100%  115.52kB/s    0:00:00 (xfer#281, to-check=2/318)
     2242683 100%    4.02MB/s    0:00:00 (xfer#282, to-check=1/318)
       32306 100%   59.08kB/s    0:00:00 (xfer#283, to-check=0/318)

sent 298377223 bytes  received 5398 bytes  20578111.79 bytes/sec
total size is 329438774  speedup is 1.10

But now that image (is this what you call it?) isn't in the list when
I run "cobbler list":

[root at intranet ~]# cobbler list
image memtest86+
[root at intranet ~]#

In fact, I haven't been able to import anything into Cobbler yet.

Kind Regards
Rudi Ahlers

Website: http://www.SoftDux.com
Technical Blog: http://Blog.SoftDux.com
Office: 087 805 9573
Cell: 082 554 7532