[CentOS] iTunes on CentOS?? [Solved]

Mon Apr 19 10:17:51 UTC 2010
ken <gebser at mousecar.com>

Thanks for link.  I should have known that wikipedia would have useful info.

The problem I was having was that I couldn't download a podcast from
iTunes.  (I figured that if I could download the file somehow, Linux
would have some way to play it.)  I installed wine and tried to install
iTunes (the software) onto that, but couldn't get it to install.  I've
been unable to discover any other possible way to connect to the iTunes
Store and, reading the link you gave, it seems that currently there
isn't any way.  This from wikipedia:

"With the release of iTunes 7.0, Apple changed their implementation of
DAAP. This change prevents any third-party client, such as a computer
running Linux, a modified Xbox, or any computer without iTunes
installed, from connecting to a remote iTunes repository. iTunes will
still connect as a client to other iTunes servers and to third-party

DAAP is the networking protocol Apple uses to move iTunes (the audio
files) around the internet and other networks.

Fortunately, a couple messages about iTunes.com failure to work with
Linux to the upstream podcast provider (Terry Gross's "Fresh Air" radio
show on NPR) found a sympathetic ear and they started posting MP3s of
their shows on their own website.  (Thanks, Terry!)

So, thanks to people at "Fresh Air" who understand Linux and the
artificial difficulties posed by commercial software, the problem has
effectively been solved.

On 04/19/2010 05:00 AM john maclean wrote:
> I have used amarok to use the media on  an ipod. Works. Be mindfull of
> the fact that it needs to "reformat something" on your device.
> http://en.wikipedia.org/wiki/Amarok_(software)
> On 14 April 2010 22:07, ken <gebser at mousecar.com> wrote:
>> Find research and analysis on US healthcare, health insurance,
>> and health policy at: <http://healthpolicydaily.blogspot.com/>
>> On 04/14/2010 03:48 PM Craig White wrote:
>>> On Wed, 2010-04-14 at 15:36 -0400, ken wrote:
>>>> On 04/13/2010 05:26 PM ken wrote:
>>>>> On 04/13/2010 05:08 PM ken wrote:
>>>>>> Anyone know how to download and play stuff from itunes.apple.com
>>>>>> (without having to use Windows or Mac)?
>>>>> Apparently iTunes installs and runs on wine.  I'm gonna try that.  Stay
>>>>> tuned....
>>>> Well, I got wine installed, but iTunesSetup.exe cannot complete its
>>>> installation.  It starts up, downloads files, but spits out a lot of
>>>> error messages of the type:
>>>> err:module:import_dll Library icuuc40.dll (which is needed by
>>>> L"C:\\Program Files\\Common Files\\Apple\\Apple Application
>>>> Support\\CoreFoundation.dll") not found
>>>> Then it says, Can't install. Try again later.
>>>> Has anyone gotten iTunes running on wine?
>>> ...
>>> I think if I recall correctly, at about Fedora 6, I was using gtkpod to
>>> access iPod (probably won't work on iPhone or iPod Touch) and mplayer to
>>> play content.
>> The actual problem is *getting* (downloading) from itunes.apple.com...
>> For this I believe it's necessary to have iTunes installed and running
>> properly.
>> _______________________________________________
>> CentOS mailing list
>> CentOS at centos.org
>> http://lists.centos.org/mailman/listinfo/centos