[CentOS] E1000 eth1 link flakiness - causes??

Tue Dec 28 03:37:21 UTC 2010
Nataraj <incoming-centos at rjl.com>

On 12/27/2010 02:37 PM, E Westphal wrote:
> On Mon, 2010-12-27 at 17:29 -0500, Ryan Wagoner wrote:
>> On Mon, Dec 27, 2010 at 5:22 PM, E Westphal <enwestph at rochester.rr.com <mailto:enwestph at rochester.rr.com>> wrote:
>> > Have  you experienced this? What's going on when this occurs? What do I need
>> > to do to keep it from occurring? Please advise. Thanks.
>> >
>> >
>> > Dec  4 10:18:28 localhost kernel: e1000: eth1 NIC Link is Up 100 Mbps Full
>> > Duplex, Flow Control: RX/TX
>> > Dec  4 10:18:29 localhost kernel: e1000: eth1 NIC Link is Down
>> What is the NIC connected to? Have you tried a different switch port
>> or network cable? Does rebooting the server make the problem go away
>> for a bit? It seems like you need to perform some basic
>> troubleshooting and let us know what you have an have no tried.
>> Ryan
>> _______________________________________________
> I've tried all the obvious things. Cables, router ports, rebooting
> etc. It's quite strange. From a cold bootup, it's fine. Then about 45
> minutes later it starts to act up. None of the obvious things seem to
> help. Then, about 90 minutes after bootup, everything is fine again!
> Rock solid! Ethtool and anything else I've tried fails to yield any
> hints, thus my question to all of you.
> _______________________________________________
> CentOS mailing list
> CentOS at centos.org
> http://lists.centos.org/mailman/listinfo/centos
Are running the latest CentOS 5.5 release with all updates installed? 
Back around 5.0 through at least 5.1, possibly even 5.2, there were some
driver bugs that affected some ethernet cards.  I have also seen
problems that showed up with cheap switch hardware and went away when
plugged into a different switch.   As far as inexpensive switches go,
the low end HP managed switches are one of the few that I've had good
luck with.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.centos.org/pipermail/centos/attachments/20101227/e15830db/attachment-0005.html>