[CentOS] perl question

Dave Cross davorg at gmail.com
Mon Feb 1 12:15:41 UTC 2010

On 29 January 2010 19:28, Jerry Geis <geisj at pagestation.com> wrote:
> I am trying to run a perl script that said it needs Net::SMPP
> I ran this:
> your_host]# *perl -MCPAN -e shell*
> cpan shell -- CPAN exploration and modules installation (v1.76)
> ReadLine support enabled
> cpan> *install Net::SNMP
> seemed to work. no errors reported.
> however when I run perl I still get the same error saying needs
>  ./sendmessage.pl
> Can't locate Net/SMPP.pm in @INC (@INC contains:
> /usr/lib64/perl5/site_perl/5.8.8/x86_64-linux-thread-multi
> /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl
> /usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi
> /usr/lib/perl5/vendor_perl/5.8.8 /usr/lib/perl5/vendor_perl
> /usr/lib64/perl5/5.8.8/x86_64-linux-thread-multi /usr/lib/perl5/5.8.8 .)
> at ./sendmessage.pl line 18.
> BEGIN failed--compilation aborted at ./sendmessage.pl line 18.
> What else do I need?

It may be too late for you, but I've added Net::SMPP to the list of
CPA modules that I have packaged into RPMs in my repository.

See http://rpm.mag-sol.com/



More information about the CentOS mailing list