[CentOS] xterm clones on VNC problem

Emmanuel Noobadmin centos.admin at gmail.com
Mon Feb 15 03:39:24 UTC 2010

Just an update, finally got some spare time to try doing this again.

Nothing better than a clean install right?

So I  yum remove nx freenx and reinstalled it.

Then following the wiki instructions, I proceeded to cp the conf
file... only to discover, there is no conf file. Although I
distinctively remember seeing them in my last attempt.

Repeated the uninstall install process again, still no conf file.

So next I tried downloading the .rpm from Nomachine just in case for
some reason those in repos was missing the conf file by some accident.
That made me realize that the Nomachine versions had 3 files,
nxclient, nxnode and nxserver, but the Centos version seems to be
missing nxnode?

Nevertheless, after downloading and I installed the nxclient since
nomachine says it contains tools used by nxnode which in turn contains
tools used by nxserver. However when I got to nxserver, it failed with
errors that the nx user already exist. After userdel nx, doing rpm
erase and install of the package seem to work.

But i still have no conf file, and obviously freenx client still
doesn't connect.

I think I've used vnc for so long that the VNC gods considered me a
valued worshipper and are probably doing their best to prevent my
apostasy and blocking my path to /freenx/paradise :D

On 1/31/10, Les Mikesell <lesmikesell at gmail.com> wrote:
> Emmanuel Noobadmin wrote:
>> Hi,
>>> Freenx is packaged, so there is nothing to installing it. The only thing
>>> remotely time-consuming is getting the unique key it puts in
>>> /etc/nxserver/client.id_dsa.key on the server side into the client, which
>>> you  can do in the GUI configuration
>> I guess you are right on that account. I got it yum installed and the
>> nxclient in Windows up in less than 5 minutes. It's been half an hour
>> since I tried to log in. Copied the users public dsa and imported it,
>> didn't work. Tried uninstalling and reinstalling with options to
>> ensure I was using the default nomachine key which hopefully the
>> windows client is setup with by default, didn't work. Although there
>> was some error about passwd being unsafe and using -f. Googling around
>> didn't turn up much useful information except some other folks were
>> having the same problem without resolution.
>> Finally tried copy and pasting the key through vnc, didn't work either.
>> So I'm giving up for now. The answer's probably in documentation
>> somewhere but  I've been going through tons of
>> documentation/readme/faqs/KB for work with more to digest that I just
>> don't have the energy to spend on something unessential for now.
>> Thanks anyway for the suggestion, will try again when I am more free.
> I don't remember having to change anything from defaults.  I usually use
> putty
> to ssh in initially and copy/paste the key contents into the NX config.
> Note
> that you aren't using the user's own key, but the one in
> /etc/nxserver/client.id_dsa.key.  The software does an initial login as the
> 'nx'
> user, using that session to encrypt the session as the real user logs in
> with a
> password. And if you leave the default (don't check the 'Disable encryption
> of
> all traffic') everything runs over the port 22 ssh connection.   But, I've
> always used gnome sessions.  It might be different if you use KDE.
> --
>    Les Mikesell
>     lesmikesell at gmail.com
> _______________________________________________
> CentOS mailing list
> CentOS at centos.org
> http://lists.centos.org/mailman/listinfo/centos

More information about the CentOS mailing list