[CentOS] Server HD failed and I think I am hosed

Slack-Moehrle mailinglists at mailnewsrss.com
Thu Feb 18 22:22:54 UTC 2010

a hd in my server failed. 

I noticed when I went to SSH in and get a copy of some files in /var/www/html
I tried to tar the files and I was told No, read-only file system.

I restarted and tried running FSCK manually (without -a or -p) and I get inode errors, short reads, etc.

I tried booting to my CentOS 53 install DVD. I do linux rescue and I get to where it wants to know where CentOS images are. I select local CD-ROM and it just spits it out at me and tells me to try someplace else. Even though I booted from the CD!

I am not sure what else to do. I dont think I can mount this on my macBook to do anything. But I really need just the data from /var/www/html. I have a backup that is a week old, but I know changes were made late last week that I would like to not have to do again....

Where is my backup of the changes I made? Well my SSD drive failed in my laptop and I dont think I have them...

Can anyone provide advice as to what to do next?

Also, what would have caused this all of the sudden? This box has been running fine for months. 

More information about the CentOS mailing list