[CentOS] Server HD failed and I think I am hosed

Steve Brooks steveb at mcs.st-and.ac.uk
Fri Feb 19 09:43:52 UTC 2010

Do not use fsck on faulty hardware.

I would remove the drive attach it to another linux box with free storage 
space on a file system larger than that of the whole damaged drive. Use 
"ddrescue" to rebuild as much of the failed drive as possible them mount 
the image produced from ddrescue and copy all you can from that.

Best Wishes,


On Thu, 18 Feb 2010, Slack-Moehrle wrote:

> a hd in my server failed.
> I noticed when I went to SSH in and get a copy of some files in /var/www/html
> I tried to tar the files and I was told No, read-only file system.
> I restarted and tried running FSCK manually (without -a or -p) and I get inode errors, short reads, etc.
> I tried booting to my CentOS 53 install DVD. I do linux rescue and I get to where it wants to know where CentOS images are. I select local CD-ROM and it just spits it out at me and tells me to try someplace else. Even though I booted from the CD!
> I am not sure what else to do. I dont think I can mount this on my macBook to do anything. But I really need just the data from /var/www/html. I have a backup that is a week old, but I know changes were made late last week that I would like to not have to do again....
> Where is my backup of the changes I made? Well my SSD drive failed in my laptop and I dont think I have them...
> Can anyone provide advice as to what to do next?
> Also, what would have caused this all of the sudden? This box has been running fine for months.
> _______________________________________________
> CentOS mailing list
> CentOS at centos.org
> http://lists.centos.org/mailman/listinfo/centos

Dr Stephen Brooks

Solar MHD Theory Group
Tel    ::  01334 463735
Fax    ::  01334 463748
E-mail :: steveb at mcs.st-andrews.ac.uk
Mathematical Institute
North Haugh
University of St. Andrews
St Andrews, Fife KY16 9SS

More information about the CentOS mailing list