[CentOS] CentOS 5.3 host not seeing storage device

Eero Volotinen eero.volotinen at iki.fi
Mon Feb 22 19:51:39 UTC 2010

2010/2/20 Sean Carolan <scarolan at gmail.com>:
>> Did you check the output of "/proc/scsi/scsi"?
> Yea, it's empty.
>> I would do a SCSI rescan using
>>   echo "- - -" > /sys/class/scsi_host/hostX/scan
> Tried this and also:
> echo 1 > /sys/class/fc_host/host0/issue_lip
> Still, nothing is seen by the host.  We have also tried changing the
> port settings from Loop, to NPIV, to Auto on the d2d device but the
> results are the same.  Unfortunately all HP's documentation is
> directed towards windows users, who simply use a GUI to discover the
> virtual drive.
>> To configure (i.e. speed and connection type) and control the QLogic FC
>> HBA I recommend to install the QLogic SANsurfer CLI.
> Ok, I may try this but I had hoped the default settings would work.
> We have no problem talking to our SAN on the same fabric, from other
> hosts with Qlogic HBAs.
>> Do you use port zoning or WWN zoning? The switch sees the attached WWNs of
>> both the server and the tape library?
> WWN zoning, and yes, the switch can see the host HBA, the virtual tape
> library and the tape changer.  I've double-checked the zone and
> refreshed it several times but no dice.
> I have a ticket open with HP, but their support folks seemed a bit
> stumped as well.  /sigh...

On some systems, reboot is required? to access disk from SAN device.

At least this issue is on my Hitachi AMS san system.


More information about the CentOS mailing list