[CentOS] Yum Issue

Kwan Lowe kwan.lowe at gmail.com
Wed Jan 6 01:48:10 UTC 2010

On Tue, Jan 5, 2010 at 8:32 PM, Clint Dilks <clintd at scms.waikato.ac.nz> wrote:
> Yum using proxy that requires authentication and a Password that
> contains the two characters \/ fails
> normally I can get yum to work with a proxy that requires authentication
> when required by doing something like
> http_proxy=http://<my username>:<my password>@<proxy server>:<proxy
> server port>
> export http_proxy
> or by filling in the appropriate information in yum.conf.
> But if the password contains the characters \/ this does not work.
> I have tried quoting the password in various ways none seem to work
> eg
> export http_proxy=\/alid at proxy.example.com:80
> export http_proxy='\/alid at proxy.example.com:80'
> export http_proxy="\/alid at proxy.example.com:80"
> export http_proxy=\\\/alid at proxy.example.com:80
> Anyone have any ideas for a work around to this that doesn't involve
> changing the password or modifying the proxy config ?
> I have tried reporting this as http://bugs.centos.org/view.php?id=4123
> but mantisbt presents the  information I submitted in a way I didn't
> expect.  If anyone can tell me how to modify the bug report to look the
> way I expected please let me know.

I've tried many, many variations of this.  There is a "proxy_username"
and "proxy_password" option (man yum.conf for the particulars) but
nothing I tried worked. I am using a Windows proxy at my work (don't
have any choice in that).

So far I've tried quoting using double and single quotes, escaping,
escaping and quoting, using the password in an environment variable,
etc.. None worked if the password contained any symbols.  I now choose
passwords with only alphanumeric characters to get around it.

More information about the CentOS mailing list