[CentOS] kickstart %pre help on C5.4

Alan McKay alan.mckay at gmail.com
Tue Jan 12 19:18:35 UTC 2010

Hey folks!

I'm doing some %pre work for the first time in a very long time, and
have been at this all day so far and still don't have anything sorted
out properly.

First I tried just doing some simple bash stuff like this

# stuff

I reduced "stuff" down to basically a simple "select" statement to
echo and read input, just for the sake of debugging.

My first problem is that when running the kickstart, the little box
would come up saying it is running the pre scripts, but my scripts
would never actually run.   No output, no prompts, nothing.

So after some muddling I tried this :

exec 1>&3
exec > /dev/tty
chvt 3
exec < /dev/tty3 > /dev/tty3
# stuff

I cannot say I really understand this - it is just something I came
across.   in any case, now my script seems to run fine, but after it
finishes it does not appear to go back to my install.  I get messages
like :

date INFO all kickstart %%pre script(s) have been run
date WARNING resolution and depth not specified, try to be sane

and that is it - it stops there.

I've also tried just :

chvt 3
# stuff

With the same results as above.

This is all running within VMWare ESXi 4.0 if that matters.

What am I missing here?


“Don't eat anything you've ever seen advertised on TV”
         - Michael Pollan, author of "In Defense of Food"

More information about the CentOS mailing list