[CentOS] Running Asterisk & Freepbx on readonly Root (Stateless System)

Alok Prasad alok.prasad7 at gmail.com
Wed Jan 13 17:17:36 UTC 2010

I am trying to Run AsteriskNow 1.5 which uses Centos 5.3 Distribution
with Readonly Root Filesytem.

Right now if I shutdown the system abrupty or there is power failure linux
doesn't not boot "Kernel panic" and other short of issues.prb due to
corrupted files.

Thats why i want to make root filesystem as read-only and placing some
/var and /etc/asterisk etc as read/write in fstab so above
problem doesn't exists.

Centos Provides fantastic experimental technolyg with only a single line
configuration to
root read-only and make it boot /etc/sysconfig/readonly-root file

Edting /etc/sysconfig/readonly-root  ->  change READONLY=no to READONLY=yes
I tried but i am not able to run asterisk and freepbx.Linux system boots up
Any one has ever tried this ..Any suggestion how to proceed with.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.centos.org/pipermail/centos/attachments/20100113/2a235351/attachment.html 

More information about the CentOS mailing list