[CentOS] CentOS-announce Digest, Vol 59, Issue 6

Tobias Weisserth tobias.weisserth at gmail.com
Mon Jan 18 21:53:32 UTC 2010

Hi everybody,

I'm having difficulties updating dhclient as outlined below by using either
yum or rpm. I'm running CentOS on a virtual guest provided by a provider.

On Fri, Jan 15, 2010 at 6:00 PM, <centos-announce-request at centos.org> wrote:

> CentOS Errata and Bugfix Advisory 2010:0042
> Upstream details at : https://rhn.redhat.com/errata/RHBA-2010-0042.html
> The following updated files have been uploaded and are currently
> syncing to the mirrors: ( md5sum Filename )
> i386:
> 75c3d86012ed835fdd8e6adf4a7b46d5  dhclient-3.0.5-21.el5_4.1.i386.rpm
> f8e9e8c6db0cfab67119d5dd22b207f1  dhcp-3.0.5-21.el5_4.1.i386.rpm
> 10065731e1acbad938b60a01a2d4437c  dhcp-devel-3.0.5-21.el5_4.1.i386.rpm
> 9c40a772d00bce2a90a28ed07341e98c  libdhcp4client-3.0.5-21.el5_4.1.i386.rpm
> bbcc62d259d5c4887d23cefba25f35c5
>  libdhcp4client-devel-3.0.5-21.el5_4.1.i386.rpm
> Source:
> 5c26195f93824372091a9cf3e61abdb3  dhcp-3.0.5-21.el5_4.1.src.rpm

This is an outline of what I tried:

yum update:

 dhclient                                 i386
  12:3.0.5-21.el5_4.1                                   updates
                    276 k

Transaction Summary
Install      0 Package(s)
Update       1 Package(s)
Remove       0 Package(s)

Total download size: 276 k
Is this ok [y/N]: y
Downloading Packages:

   | 276 kB     00:00
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Updating       : dhclient

Error unpacking rpm package 12:dhclient-3.0.5-21.el5_4.1.i386
error: unpacking of archive failed on file /var/lib/dhclient: cpio: mkdir

  dhclient.i386 12:3.0.5-21.el5_4.1

[root at vps ~]# wget
--2010-01-18 21:46:49--
Resolving mirror.centos.org...
Connecting to mirror.centos.org||:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 282677 (276K) [application/x-rpm]
Saving to: `dhclient-3.0.5-21.el5_4.1.i386.rpm'

282,677     --.-K/s   in 0.1s

2010-01-18 21:46:50 (1.87 MB/s) - `dhclient-3.0.5-21.el5_4.1.i386.rpm' saved

[root at vps ~]# md5sum dhclient-3.0.5-21.el5_4.1.i386.rpm
75c3d86012ed835fdd8e6adf4a7b46d5  dhclient-3.0.5-21.el5_4.1.i386.rpm
[root at vps ~]# rpm -U dhclient-3.0.5-21.el5_4.1.i386.rpm
error: unpacking of archive failed on file /var/lib/dhclient: cpio: mkdir
failed - No such file or directory

What's wrong? I did some other package updates using yum earlier and with
the exception of this package it worked.

The filesystem is not full. There's plenty of space. Everything is mounted
under /

Any ideas?


Tobias Weisserth
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.centos.org/pipermail/centos/attachments/20100118/9888190c/attachment.html 

More information about the CentOS mailing list