[CentOS] The directory that I am trying to clean up is huge

m.roth at 5-cent.us m.roth at 5-cent.us
Mon Jan 25 14:39:00 UTC 2010

> fred smith wrote:
>> On Mon, Jan 25, 2010 at 03:14:54AM -0800, John Doe wrote:
>>> From: Anas Alnaffar <a.alnaffar at tijaritelecom.com>
>>>> I tried to run this command
>>>> find -name "*.access*" -mtime +2 -exec rm {} \;
>>>> and I have same error message
>>> How many "*.access*" are there...?
>> if there are so many that you're finding the previously suggested
>> techniques difficult to use, you can try the brute-force I sometimes
>> use...
> It actually shouldn't matter.  As long as the wildcards are quoted on the
> command line, you shouldn't get an error from too many files.  I suspect
> the command that was typed wasn't exactly what is shown above.

First, I don't see the path there, which *must* be after the command....

Also, I don't believe that "" will work - the shell will interpret that. I
think you need '', or, what I always use, \, so that if I were typing it,
I'd have:
$ find . -name \*.access\* -mtime +2 -exec rm {} \;


More information about the CentOS mailing list