[CentOS] Yum Issue

Wed Jan 6 01:32:09 UTC 2010
Clint Dilks <clintd at scms.waikato.ac.nz>

Yum using proxy that requires authentication and a Password that 
contains the two characters \/ fails

normally I can get yum to work with a proxy that requires authentication 
when required by doing something like

http_proxy=http://<my username>:<my password>@<proxy server>:<proxy 
server port>
export http_proxy

or by filling in the appropriate information in yum.conf.

But if the password contains the characters \/ this does not work.
I have tried quoting the password in various ways none seem to work


export http_proxy=\/alid at proxy.example.com:80
export http_proxy='\/alid at proxy.example.com:80'
export http_proxy="\/alid at proxy.example.com:80"
export http_proxy=\\\/alid at proxy.example.com:80

Anyone have any ideas for a work around to this that doesn't involve 
changing the password or modifying the proxy config ?

I have tried reporting this as http://bugs.centos.org/view.php?id=4123 
but mantisbt presents the  information I submitted in a way I didn't 
expect.  If anyone can tell me how to modify the bug report to look the 
way I expected please let me know.