[CentOS] Xorg without xorg.conf (a bit OT)

Thu Jan 21 09:37:11 UTC 2010
Ron Blizzard <rb4centos at gmail.com>

I like to try out other distributions of Linux. Today I took a look at
Mint Linux 8 and Fedora 12. I installed and updated each on a small
partition -- actual physical install, not virtual machines. Both
worked great at 1280x1024 (their defaults) but neither would let me
use 1024x768 resolution. Both came with newer versions of Xorg,
neither of which build an xorg.conf file. Mint gave me three settings,
1280x1024, 640x480 and something like 700x400(?). Fedora gave me the
choice of 1024x768, but when I tried to use it, it just went black
until timing out. When I downloaded and ran system-config-display, it
built an xorg.conf file, which I modified to 1024x768 (by removing the
1280x1024 selection). When I tried rebooting, it locked up. (I have an
Intel 865G video chip, BTW.)

So, what is it about the newer versions of Xorg that doesn't like
1024x758 resolution? At least not on an Intel Graphics chip? Just

And I'm curious as to how Xorg determines its monitor resolution
choices when there is no xorg.conf file. Is there a good tutorial on
this subject available? Frustrating situation -- and I'm still nervous
that Red Hat 6 is going to end up with the same issue -- if this is an
Xorg problem with Intel it seems reasonable to assume that they will
inherit it.

RonB -- Using CentOS 5.4