[CentOS] yum install -y gcc?

Thu Jan 14 12:13:47 UTC 2010
Jake Shipton <jakems at hotmail.co.uk>

On 14/01/10 09:49, Peter Kjellstrom wrote:
> On Thursday 14 January 2010, John Doe wrote:
>> From: hadi motamedi <motamedi24 at gmail.com>
>>> I tried to install GCC3.x , required to compile Asterisk , on my CentOS 5
>>> server as the followings : #yum install -y gcc
>> First, didn't you intend to install compat-gcc-34 ?
>> 'yum install gcc' would install gcc 4.x
>>> But in the middle of the installation , my server went down from
>> sudden power cut . After power recovery , I tried again but I am facing
>> with the following error :
>>> "Error:Missing dependency : libstdc++-devel = 4.1.2-46.el5_4.1 is needed
>>> by package gcc-c++" Can you please let me know what is its meaning and
>>> how I can proceed to re-install it ?
>> Try 'yum clean all'.
> He may want "yum-complete-transaction" from the pkg yum-utils if transactions 
> were interrupted.
> /Peter
> _______________________________________________
> CentOS mailing list
> CentOS at centos.org
> http://lists.centos.org/mailman/listinfo/centos
Yes, that's what you want to do (or should) :-)

If that don't work just generally try stuff such as:

yum remove gcc
That should remove a half installed package, if it managed to be
partially installed. (and marked as installed. Doesn't always work)

yum install libstdc++-devel
Possibly to see if it can find the package?

else, try all things others have suggested (Mostly,
yum-complete-transaction & yum clean all)

Also you may want to invest in a UPS ;-)