[CentOS] apcupsd

Fri Jan 22 20:13:36 UTC 2010
m.roth at 5-cent.us <m.roth at 5-cent.us>

> m.roth at 5-cent.us wrote:
>> Here's an odd one: I installed apcupsd, and it works with most of our
>> UPSs. I'd swear it worked on this one. Then I replaced the Gin-u-wine
>> APC batteries, which were dead, with new ones, non-APC. They're just dumb
>> batteries, no chips or whatever on them.
>> If I hook it up using a serial cable, I can get info. If I hook it up
>> the way I had it, with APC's weird USB cable - and this is the way it was
>> working before - it fails. I run apctest, and it gives me:
>> Attached to driver: usb
>> sharenet.type = DISABLE
>> cable.type = USB_CABLE
>> You are using a USB cable type, so I'm entering USB test mode
>> mode.type = USB_UPS
>> Setting up the port ...
>> Hello, this is the apcupsd Cable Test program.
>> This part of apctest is for testing USB UPSes.
>> Getting UPS capabilities...SUCCESS
>> Then I tell it to do the self test, and get:
>> This test instructs the UPS to perform a self-test
>> operation and reports the result when the test completes.
>> Clearing previous self test result...CLEARED
>> Initiating self test...INITIATED
>> Waiting for test to complete...ERROR READING STATUS
>> 12.976 apcupsd: linux-usb.c:802 HIDIOCGREPORT for function
>> SelftestStatus
>> failed. ERR=Input/output error
>> Now, I've even found an rpm that was *not* two+ years old, as what comes
>> with CentOS 5.4, current update, and get the same error.
>> In addition, even though the batteries are fully charged, and the info I
>> get via the serial cable says they're at 100%, the red "change battery"
>> light is still on on the front of the UPS. Hitting the "test" button
>> doesn't help; I was hoping running the self-test that's available via
>> the
>> USB connection would reset it, but I can't do that.
>> Any clues for the poor?
> Funny, after reading the above, I decided to try the apcupsd with my new
> fancy APC with the LCD display and everything. Got very similar results.
> Gnome Power Manager recognizes it from the get go, just with decreased
> functionality. It would be nice to have Centos able to 'plug' into all
> of its features and diagnostics. I'm  running 5.4 on a hardware raid 10
> server....old Adaptec 2400A with 128 megs of cache. This machine seems
> to have problems with the partition managers as well. Could LVM be
> getting in the way somehow?

Nope - we're not using LVM. And apcupsd's apctest is command line.