[CentOS] Skype and problem with ALSA mixer driver?

Fri Jan 29 19:51:25 UTC 2010
Andrew <andy.allen at virgin.net>

On Fri, 2010-01-29 at 11:03 -0800, Akemi Yagi wrote:
> On Fri, Jan 29, 2010 at 10:44 AM, Andrew <andy.allen at virgin.net> wrote:
> >> What version of ALSA driver are you using? Have you tried updating ALSA
> >> as the version within CentOS is quite old now (1.0.14rc3).
> >>
> >> Elrepo has an updated ALSA driver package here:
> >>
> >> http://elrepo.org/tiki/kmod-alsa
> >>
> > Thanks for that useful information, but can you tell me exactly how to
> > perform the update? I tried 'yum update *alsa*' as I have the Elrepo
> > repository installed, but it came up with 'No Packages marked for
> > Update'. Do I need to completely remove all the currently installed ALSA
> > packages and then do 'yum install kmod-alsa? Any advice gratefully
> > received, thanks.
> Perhaps, you do not have elrepo enabled (default behavior) ?  In that case, try:
> yum --enablerepo=elrepo install kmod-alsa
> Akemi

Many thanks,
I've installed kmod-alsa OK but the mic is still not working (with
skype). Do I need to remove the old ALSA packages alsa-lib and
alsa-utils? - because when I type 'yum erase alsa-lib alsa-utils' it
wants to remove 123 packages!