[CentOS] Audio fails on centos 5.5 sony laptop - snd-hda-intel

Sun Jul 18 02:19:17 UTC 2010
Rob Kampen <rkampen at kampensonline.com>

Hi List, been chasing my tail for the last two hours and getting nowhere 
on my wifes laptop.
I only do updates monthly on her machine, as it is safely behind 
firewalls and only does email and browser stuff.
I have never had audio problems on this laptop, Centos just worked from 
day one - even the wireless.

It appears that the 5.5 kernels and related audio driver snd-hda-intel 
do not function.
If I reboot into 2.6.18-164.15.1.el5.centos.plus all is well.
$ cat /proc/asound/cards
 0 [Intel          ]: HDA-Intel - HDA Intel
                      HDA Intel at 0x80000000 irq 169
 1 [U0x46d0x804    ]: USB-Audio - USB Device 0x46d:0x804
                      USB Device 0x46d:0x804 at usb-0000:00:1d.7-3, high 

Neither 2.6.18-194.3.1.el5.centos.plus or 2.6.18-194.8.1.el5.centos.plus 
have functioning sound.
on these kernels I get
$ cat /proc/asound/cards
 0 [U0x46d0x804    ]: USB-Audio - USB Device 0x46d:0x804
                      USB Device 0x46d:0x804 at usb-0000:00:1d.7-3, high 

yet lsmod shows
snd_hda_intel         472337  0
snd_seq_dummy           7877  0
snd_seq_oss            32577  0
snd_seq_midi_event     11073  1 snd_seq_oss
snd_seq                49585  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_pcm_oss            42817  0
snd_usb_audio          77761  2
snd_mixer_oss          19009  1 snd_pcm_oss
snd_pcm                72133  3 snd_hda_intel,snd_pcm_oss,snd_usb_audio
snd_usb_lib            19137  1 snd_usb_audio
snd_rawmidi            26561  1 snd_usb_lib
snd_timer              24517  2 snd_seq,snd_pcm
snd_page_alloc         14281  2 snd_hda_intel,snd_pcm
snd_seq_device         11725  4 
snd_hwdep              12869  2 snd_hda_intel,snd_usb_audio
snd                    55749  15 
soundcore              11553  1 snd

So I remembered the bug rh introduced with the 194 kernels and nvidia 
chipsets (not my case but I'm desperate) and added the enable_msi=0 so 
that my modprobe.conf is now
options snd cards_limit=8
alias snd-card-0 snd-hda-intel
options snd-hda-intel index=0 enable_msi=0

but it still will not work.
I am getting frustrated at the retrograde steps that seem to be hitting 
kernel and 5.x upgrades lately.
yum update used to just work, get me the latest patches and all was well 
- after all that is why I use Centos.
I have tried modprobe -r to remove and reload module but to no avail.
Anyone have any ideas as to what I try next?
Google has not given me any ideas yet.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: rkampen.vcf
Type: text/x-vcard
Size: 123 bytes
Desc: not available
URL: <http://lists.centos.org/pipermail/centos/attachments/20100717/174a5d0a/attachment-0002.vcf>