[CentOS] Problem with yum

Mon Jul 19 17:00:14 UTC 2010
James B. Byrne <byrnejb at harte-lyne.ca>

I am experiencing a problem with yum on one of my CentOS-5.5
systems.  Specifically, on Friday past (July 16), I ran yum update
as root.  Yum displayed all of the outdated packages and asked if I
wanted to proceed.  An answered yes.  This first package downloaded
was nss.  At this point yum simply stopped processing or responding.
 A ctrl-c at the yum session terminal window did not interrupt the
task.  Top did not display any yum processes.

I killed that particular process to regain the console session, but
I had to use -9 because nothing else worked.  Yum continues to
behave in this strange manner.   Any invocation of yum with any
option just stops responding.

Before I manually remove yum and reinstall it using rpm could anyone
provide a clue as to what might be happening here and how it might
be cured.  I found this one entry from yum in the log files:

/var/log/messages.1:Jul 16 00:14:43 gway01 kernel: Out of memory:
Killed process 1380, UID 0, (yum-updatesd-he).

However, this entry occurred some time before I attempted my update
task later that same morning.

I would like to be directly copied on any replies as I am a digest


***          E-Mail is NOT a SECURE channel          ***
James B. Byrne                mailto:ByrneJB at Harte-Lyne.ca
Harte & Lyne Limited          http://www.harte-lyne.ca
9 Brockley Drive              vox: +1 905 561 1241
Hamilton, Ontario             fax: +1 905 561 0757
Canada  L8E 3C3