[CentOS] Strange misbehavior from system-config-printer on CentOS 5.5

Thu Jul 29 01:51:17 UTC 2010
Mark <mhullrich at gmail.com>

I had to print a file directly from my VMWare Windows XP guest to my
Brother laser printer and now I can't run system-config-printer.

The file was one of those screwy PDFs that even Adobe Reader 9.3.2
can't print on my CentOS (there's something in the file that inhibits
the printing).  Occasionally I've been able to get around this in the
past by using the GIMP to reformat some pages in such files, but this
one is 56 pages and I needed to print the whole thing.

I tried printing it through the PDFCreator on the Windows guest, but
that PDF also would not print.  I tried printing it to a file on both
the CentOS host in AR and the Windows guest (also with AR), but the
resulting PS file is unreadable - the document viewer shows "Keyed
info" on every page and nothing else.

So, I used the VMWare Removable Devices feature to attach the printer
to the Windows guest and the file printed fine.

In the past, this has forced me to power off the printer for CentOS to
be able to use it again, and I did that, too, but not right away.

First I tried to print a test page with CUPS.  That failed, so I
canceled the print job.  Then I tried to start system-config-printer -
nothing.  I got the security shield on my panel but no s-c-p window.

I unpublished the printer and stopped it with CUPS, power cycled it,
then re-started and re-published it.  This time CUPS was able to print
the test page, but s-c-p seems to be dead.  The most I get is a small
window marker on the panel that says "Starting Printing" and then it
goes away.

I didn't see anything relevant in the /var/log logs, but I'm not sure
which log to look in.

Any ideas on what happened?