[CentOS] xulrunner-devel dependencies

Thu Jul 1 14:50:33 UTC 2010
Bowie Bailey <Bowie_Bailey at BUC.com>

John Doe wrote:
> From: Bowie Bailey <Bowie_Bailey at BUC.com>
>> What's the deal with all of the new dependencies for xulrunner-devel 
>> in the last update?  I'm updating my servers and the update for
> Dunno, but:
> # yum install xulrunner-devel
> ...
> Installing:
>  xulrunner-devel                i386        updates     4.1 M
> Installing for dependencies:
>  libXt-devel                    i386     1.0.2-3.2.el5        base        330 k
>  libnotify-devel                i386     0.4.2-6.el5          base         19 k
>  startup-notification-devel     i386     0.8-4.1              base        8.6 k
> ...
> Install       4 Package(s)
> Upgrade       0 Package(s)
> Maybe you were not up to date on many packages?

Maybe you already had the dependencies installed for something else. 
What I'm seeing is that I already had an older version of
xulrunner-devel installed without all of the dependencies and then when
I do an update to the newer version, I get an extra 43 dependencies.

Since I don't need it (AFAIK), I just removed the package and that
solved (or at least worked around) the problem.  But it still doesn't
make sense.  A new version of a package sometimes has a few new
dependencies, but 43 is a bit much.