[CentOS] DSL battling rojter - help!

Sun Jul 18 17:31:42 UTC 2010
Cia Watson <ciamarie at my180.net>

On 07/18/10 07:58 AM, Mark wrote:
> If I run ifup eth0, here's what I get:
> eth0    Link encap:Ethernet  HWaddr 00:1E:90:F3:D2:8D
>            inet addr:  Bcast:  Mask:
The mask: above looks right, but down below:

Local Network
> Modem IP Address
> Ethernet Status		Connected
> In this shape, I can ping, say, google.com from the modem and get a response.
> But, when I run dhclient, I get this:
> # dhclient
> Internet Systems Consortium DHCP Client V3.0.5-RedHat
> Copyright 2004-2006 Internet Systems Consortium.
> All rights reserved.
> For info, please visit http://www.isc.org/sw/dhcp/
> /sbin/dhclient-script: configuration for vmnet8 not found. Continuing
> with defaults.
> /etc/sysconfig/network-scripts/network-functions: line 78: vmnet8: No
> such file or directory
> Listening on LPF/vmnet8/00:50:56:c0:00:08
> Sending on   LPF/vmnet8/00:50:56:c0:00:08
> Listening on LPF/eth0/00:1e:90:f3:d2:8d
> Sending on   LPF/eth0/00:1e:90:f3:d2:8d
> Sending on   Socket/fallback
> DHCPREQUEST on vmnet8 to port 67
> DHCPREQUEST on eth0 to port 67
> DHCPACK from
> bound to -- renewal in 291 seconds.
And on the above, the mask is: I don't run dhclient or 
anything so I'm not sure where the config file is, but I'd suggest that 
in addition to what's already been suggested you probably want to change 
the above to have a subnet mask matching what comes up under the ifup,