[CentOS] Audio fails on centos 5.5 sony laptop - snd-hda-intel

Tue Jul 20 15:48:09 UTC 2010
Akemi Yagi <amyagi at gmail.com>

On Tue, Jul 20, 2010 at 2:55 AM, Ned Slider <ned at unixmail.co.uk> wrote:
> On 20/07/10 03:08, Rob Kampen wrote:
>> Still no joy - I am at a loss to know what to check - if I boot a 194
>> kernel no sound, 164 kernel is fine - why the regression?
>> Same configs, same modules loaded but now no sound - what can I check to
>> determine problem and find a solution?
>> no errors in logs or dmesg
> I would suggest you start checking back through the changelogs between
> kernel-2.6.18-194.el5 and kernel-2.6.18-164.el5, find likely candidates
> that may have caused your issue and then rebuild a testing kernel with
> that patch reverted. If that testing kernel fixes your issue then you've
> identified the issue and can file a bug report upstream.
> To start you on your way, this patch looks like a likely candidate for
> you to investigate further:
> * Mon Dec 21 2009 Jarod Wilson <jarod at redhat.com> [2.6.18-183.el5]
> - [sound] alsa hda driver update for rhel5.5 (Jaroslav Kysela) [525390]


I understand you have already tried a workaround reported in:


According to comment #10 in there, Gary Gatling built a test kernel
with the above alsa patch removed. You might want to try asking him
for the kernel he built if you do not feel like building it yourself.