[CentOS] X server crashes when I fire up "Display" or "Screen Resolution" control panels

Aleksey Tsalolikhin atsaloli.tech at gmail.com
Thu Mar 4 19:52:53 UTC 2010

Hi.  I've just installed CentOS 5.4 on my IBM T61 laptop.

By default, I get the same image (duplicate screens) on the
laptop's LCD and on the external monitor; I want to set up
separate screens but my X server crashes when I start
"Display" or "Screen Resolution" control panels or press
Function-F7 which is supposed to bring up the single screen/
multiple screens selection menu.

I am including my Xorg.log, could somebody help me sort
this out, please, or at least point me in the right direction?

I do see this:

(WW) intel: No matching Device section for instance (BusID PCI:0:2:1) found

(--) PCI:*(0:2:0) Intel Corporation unknown chipset (0x2a02) rev 12,
Mem @ 0xf8100000/20, 0xe0000000/28, I/O @ 0x1800/3
(--) PCI: (0:2:1) Intel Corporation unknown chipset (0x2a03) rev 12,
Mem @ 0xf8200000/20

Do I need a special video driver?

I checked http://www.linlap.com/wiki/ibm-lenovo+thinkpad+t61 which says
this laptop should work OK with recent Linux distros; and I tried the xorg.conf
mod in http://www.thinkwiki.org/wiki/Installing_Fedora_8_on_a_T61#Graphics
but X crashes when I run xrandr.

I went on the vendor website but there is no driver available - they did have
an NVIDIA driver for SUSE, but my laptop does not have an NVIDIA device
and I am running CentOS, not SUSE!



More information about the CentOS mailing list