[CentOS] LSI software raid with centos 5.4

Mon May 24 09:10:29 UTC 2010
CList <centoslist at gmail.com>

>> I have been trying to install CentOS 5.4 on a Intel SR1530SHS, Intel
>> mainboard.. It has a 3 x 1TB sata hotswap drives with LSI software raid
>> onboard.
>> I had configured the LSI to have Sata0 and Sata1 with raid 1 and the
>> drive as a hotspare drive.
>> Format the harddisk and installation was a breeze. The server rebooted
>> a blank screen and the cursor just keep blinking.


> I've had this problem on an Intel board when I had hard drives on the
> motherboards SATA ports and some on the motherboards silicon image
> SATA ports. The bios seemed to swap the order the drives were present
> to grub so it couldn't boot. I would either get a blinking cursor or
> GRUB. I ended up putting all the drives on a LSI PCI Express card and
> everything just worked. However in your situation it sounds like you
> only have drives on the LSI controller.
> I would try booting into resuce mode with the CentOS installation CD.
> You can do this by typing linux rescue. Have it search and mount the
> CentOS installation. Look at /boot/grub/device.map and make sure hd0
> references the correct /dev/sd device. Also chroot /mnt/sysimage and
> try grub-install /dev/sd


I followed your instruction, but it is still not working. Any other