[CentOS] Mounting LVM disk

Mon May 24 15:16:58 UTC 2010
Brian Mathis <brian.mathis at gmail.com>

On Mon, May 24, 2010 at 10:28 AM, Weiner, Michael <weinerm at ccf.org> wrote:
> List Readers –
> I have a Dell server that uses the Perc 6i controller and had 5 1Tb disks
> installed (1 for OS and the other 4 in a Raid0 for a large storage pool).
> The owner of the server wanted me to swap out the 1Tb disks for 2Tb disks –
> easy enough I thought, but I ran into some issues trying to clone the OS
> disk to the new 2Tb disk, so I just did a re-install. So basically we now
> have 5 2Tb disks (1 for OS and the other 4 in a Raid0) like before. I was
> able to copy off the data that was on the original Raid0 volume and put it
> back on the newly created one that is now 8Tb and that worked well enough.
> But since I was unable to clone the original OS disk, and proceeded to
> simply re-install the OS, the owner apparently wants his $HOME directory
> copied off (which of course resides on the 1Tb OS disk). So, being a SAS
> disk, I purchased an ICY Dock which allows me to mount the SAS disk in an
> external enclosure, and plug it in via USB (SAS -> SATA -> USB). However
> when I do a ‘fdisk –l /dev/sdc’ I receive the following:
> [root at gc-server2 ~]# fdisk -l /dev/sdc
> Disk /dev/sdc: 2199.0 GB, 2199023255552 bytes
> 255 heads, 63 sectors/track, 267349 cylinders
> Units = cylinders of 16065 * 512 = 8225280 bytes
> Disk /dev/sdc doesn't contain a valid partition table
> Two things are a bit unusual here, first of all its not a 2Tb disk, and
> secondly why cant I read the partition table.
> Originally the OS was on an LVM volume and by default it was setup as
>  /dev/VolGroup00/LogVol00 /                       ext3    defaults        1
> 1
> My question is, is there a way to connect and mount this via USB and be able
> to get the $HOME directory stuff off that I failed to copy off before
> removing the disk?
> Thanks in advance
> Michael

Since the disk was connected through a RAID controller it's most
likely that the disk is formatted for the custom format that the RAID
controller uses.  The controller then presents that disk to the OS.
You're going to have to put the drive back into the server so the PERC
can see it, then you might be able to get to the LVMs.

PS. You did something like this without making backups first?

PPS. You might have a reason, but it would be irresponsible not to
point out that by using RAID0 you now have an exponential risk of
losing all of that data.