[CentOS] kernel bug ?

My LinuxHAList mylinuxhalist at gmail.com
Fri Nov 12 21:25:12 UTC 2010


I was using kernel-2.6.18-164.15.1 with no known issues. Then, I updated to:
Linux 2.6.18-194.17.1.el5 #1 SMP Wed Sep 29 12:50:31 EDT 2010 x86_64
x86_64 x86_64 GNU/Linux

I'm aware that there are later updates that patch couple more security bugs.

Here is an issue I run with 2.6.18-194.17.1 and am asking if anyone
hits that kernel bug.

Here are the symptoms:
1) kswapd1 running at 100%, there are not much paging
2) when i logged in, root can't kill -9 ANY processes
3) memory is used up, swap is probably only used up for couple hundred
MBs at most (Swap space has couple Gig available)

I saw in the logs:
kernel: INFO: task sadc:23936 blocked for more than 120 seconds.
kernel: "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables
this message.

Annoyingly, I failed to reproduce the issues.

I tried to reproduce it with the "stress" software package, using up
CPU, memory, etc. But I failed to reproduce those.
Reading later release of kernel did not mention this bug.

If anyone can contribute to what is happening here, that would be great.


More information about the CentOS mailing list