[CentOS] Confused about Java browser plugin for Firefox

Przemysław Pawełczyk pp_o2 at o2.pl
Sun Nov 14 09:53:54 UTC 2010

On Sun, 14 Nov 2010 09:18:24 +0100
Przemysław Pawełczyk <pp_o2 at o2.pl> wrote:

> Hi,
> I missed the most posts of the thread so let me say those few words.
> First of all I use Java or OpenOffice.org from producers' websites.
> They are always "fresh" and installable in RHEL.
> I assume too, that the i386 and amd64 versions work the same way, only
> the lib names can be different.
> Thirdly, I cannot say now what method I used lately but either of them
> worked flawlessly. I installed Scientific Linux (CentOS) several times
> without any snags.
> So,
> 1. The latest Java is attached to the latest OpenOffice.org RPMs.
> http://download.openoffice.org/other.html
> 2. Java RPM can be downloaded from Oracle page:
> http://www.java.com/en/download/linux_manual.jsp?locale=en&host=www.java.com
> test Java:
> http://www.java.com/en/download/help/testvm.xml
> Java directory with Java libs and plugins:
> /usr/java/jre1.6.0_21/lib/amd64
> I use to place OpenOffice.org in /opt directory. Java is installed
> here: /opt/openoffice.org/ure
> It must be working as it always worked here. ;-)


A few words on plugin directories.

Typical Linux directory /usr/share/mozilla/plugins does not work here.
The right place for plugins in RHEL amd64, as in my 64bit example, is:

I had to find out that because the libnpjp2.so library wasn't placed in
user's ~/.mozilla/plugins directory and what made me so confused
wondering why my Firefox 3.6.11 read the java pages without the
library! :-)

Summing up - the best way to find out what works or why something
doesn't is a "small step approach" - trying to make use of the latest
libs or apps from developers websites - not from the main repos for our
system releases.


>>> Please do NOT Cc me on Mailing Lists <<<
Przemysław Pawełczyk (P2O2) [pron. Pshemislav Paveltchick]
http://pp.blast.pl, pp_o2 at o2.pl
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
URL: <http://lists.centos.org/pipermail/centos/attachments/20101114/6e524944/attachment.sig>

More information about the CentOS mailing list