[CentOS] something chmod'ing /dev/null

Joe Pruett joey at q7.com
Wed Nov 17 18:45:19 UTC 2010

On 11/17/2010 10:35 AM, Robert Heller wrote:
> At Wed, 17 Nov 2010 10:16:51 -0800 CentOS mailing list <centos at centos.org> wrote:
>> it looks like one of the recent updates will sometimes chmod /dev/null
>> to 600.  out of 20 machines i've updated, 3 of them had the odd
>> /dev/null perms afterwards.  i haven't tried to identify what it doing
>> it yet, but wanted to give a heads up to others that might start seeing
>> weird behavior.
> Look in /etc/udev/rules.d/50-udev.rules.  My copy has the line:
> KERNEL=="null",                 MODE="0666", OPTIONS="last_rule"
> You haven't managed to mess with this rule?  
no changes to udev rules.  and this happens immediately after the update
is run, no reboot required.  what is weird is that the config on the
systems i run are pretty close to each other, so why only a few got hit
by this is odd.  i had one happen yesterday and thought i had just done
something stupid, but then more popped up today immediately after doing
updates, so that is why the warning.

More information about the CentOS mailing list