[CentOS] Fail Transfer of Large Files

Tue Nov 23 05:11:29 UTC 2010
Nico Kadel-Garcia <nkadel at gmail.com>

On Sun, Nov 21, 2010 at 10:13 PM, Michael D. Berger
<m_d_berger_1900 at yahoo.com> wrote:
> On Sun, 21 Nov 2010 11:49:29 -0500, Nico Kadel-Garcia wrote:
> [...]
>> Good question. I don't have a hard rule of thumb, but I'd estimate that
>> any one file that takes more than 10 minutes to transfer is too big. So
>> transferring CD images over a high bandwidth local connection at 1
>> MByte/second, sure, no problem! But for DSL that may have only 80
>> KB/second, 80 KB/second * 60 seconds/minute * 10 minutes = 48 Meg. So
>> splitting a CD down to lumps of of, say, 50 Megs seems reasonable.
> [...]
> The file I was having trouble with was a tar file of a complex
> directory tree containing mostly jpg files under 15M in size.
> So instead I did rsync -rv on the unpacked directory tree, and it
> worked just fine.  PROBLEM SOLVED.

Good for you. Next time, use "rsync -avH". "-H" preserves hardlinks,
"-a" preserves lots of other useful characteristics, such as symlinks
and full ownership and permissions.