[CentOS] Openwebmail emergency (Perl)

Tue Oct 12 07:13:45 UTC 2010
Sean Hart <boardnutz at blacklight.net>

  On 10/11/10 11:51 PM, Jussi Hirvi wrote:
> It seems Openwebmail is using Perl-Compress-Zlib from rpmforce, but in
> Centos this is obsoleted by Perl-IO-Compress, and there is a conflict.
> This I got when I tried to install the rpmforce package:
> [root at mail log]# yum install perl-Compress-Zlib
> Loaded plugins: fastestmirror, installonlyn
> Loading mirror speeds from cached hostfile
>    * addons: ftp.funet.fi
>    * base: ftp.funet.fi
>    * extras: ftp.funet.fi
>    * rpmforge: wftp.tu-chemnitz.de
>    * updates: ftp.funet.fi
> Setting up Install Process
> Package perl-Compress-Zlib is obsoleted by perl-IO-Compress, trying to
> install perl-IO-Compress-2.030-2.el5.rf.noarch instead
> Package perl-IO-Compress-2.030-2.el5.rf.noarch already installed and
> latest version
> Nothing to do
In that case, it depends on how brave/desperate you are ;)

First off... You had better have a backup of your system.  If you don't 
already, you've learned a valuable lesson, but still get one RIGHT NOW.

Is there anything on the Openwebmail forums/mailing lists?  I can't 
imagine you are the only one facing this.

Next, you could try removing the conflict or getting the required Zlib 
package (rpm or sourced from cpan) and force install, but I don't really 
recommend.  I don't use Openwebmail, so I can't speak to the 
requirements there.

Good luck,