[CentOS] Issue with Perl and rpmforge - advice?

Steve Huff shuff at vecna.org
Wed Sep 1 22:45:28 EDT 2010

On Sep 1, 2010, at 9:51 PM, Mark wrote:

> I have an old version of rkhunter installed on my CentOS 5 machine,
> one I got from rpmforge.
> In my most recent attempts to update this, I get the following errors in yum:

hi Mark!  you have a couple of different issues going on here.

first off, a more appropriate forum for this question is probably the RPMforge users list, <users at lists.rpmforge.net>.  let's take the conversation over there, so that we don't spam everyone.

rkhunter has, as best i can tell, no connection with perl-AnyEvent, which is the package that is triggering your conflict; it looks like you may be trying to updated several packages at once.  please try running just

$ sudo yum update rkhunter

and let me know (over on the users list) how that works for you.

> Resolving Dependencies
> --> Running transaction check
> ---> Package perl-AnyEvent.noarch 0:5.240-1.el5.rf set to be updated
> ...
> --> Finished Dependency Resolution
> perl-AnyEvent-5.240-1.el5.rf.noarch from rpmforge has depsolving problems
>  --> Missing Dependency: perl(Net::SSLeay) >= 1.33 is needed by
> package perl-AnyEvent-5.240-1.el5.rf.noarch (rpmforge)
> Error: Missing Dependency: perl(Net::SSLeay) >= 1.33 is needed by
> package perl-AnyEvent-5.240-1.el5.rf.noarch (rpmforge)
> ...
> This seems to be because my current perl installation has the following:
> perl-Net-SSLeay.x86_64                     1.30-4.fc6                  installed
> IIRC, this is part of the base perl package, which repo has higher
> priority than the rpmforge repo (of course), which in turn makes the
> rpmforge perl packages invisible.

not quite; there is indeed a perl-Net-SSLeay package that comes from upstream, but it's a separate package (as your yum output shows), not part of the base perl package (perl-5.8.8-32.el5_5.1 at the time of writing).

> Questions:
> 1) Are the newer perl packages from rpmforge compatible with the
> installed base perl packages?

many packages from RPMforge install cleanly without replacing any upstream packages; some, on the other hand, do require later versions of packages than are available from upstream.  i'm not sure quite what you're asking; when you try to install a package that needs to clobber an upstream package, you'll see yum output similar to what you're seeing now, and then you need to decide how badly you want the newer version.

> 2) What other implications should I be looking for if I try this
> (other than the obvious caveat about other rpmforge rpms breaking
> other base rpms)?

there's more discussion of a similar issue over here:


in brief:

if you don't want to clobber the upstream perl-Net-SSLeay package, then you don't get to safely install perl-AnyEvent-5.240, and you need to stay on an older version of perl-AnyEvent.  on the other hand, if you want the latest perl-AnyEvent, then you need to replace the perl-Net-SSLeay package that you got from upstream.

> There's a fair amount of perl support in the installed base, I just
> want to be sure I'm not likely to break it.

sounds like it's a good idea to roll out this change on a test system before you deploy it on your production systems, then :)


If this were played upon a stage now, I could condemn it as an improbable fiction. - Fabian, Twelfth Night, III,v

-------------- next part --------------
A non-text attachment was scrubbed...
Name: PGP.sig
Type: application/pgp-signature
Size: 195 bytes
Desc: This is a digitally signed message part
Url : http://lists.centos.org/pipermail/centos/attachments/20100901/4714d3f9/attachment.bin 

More information about the CentOS mailing list