[CentOS] new kernel = no working sound

Rob Kampen rkampen at kampensonline.com
Sun Apr 10 17:45:12 UTC 2011

On Apr 10, 2011, at 10:35 AM, Iulian L Dragomir <iulianld at gmail.com> wrote:

> After updating my laptop ( compaq 6820s) to Centos 5.6 the sound is gone.
> The sound card is still detected but there is no sound from speaker
> Vendor: Intel Corporation
> Model: 82810H (ICH8 Family) HD Audio Controller
> Module: snd-hda-intel
> On the same updated laptop the sound is working fine with an older
> kernel ( 2.6.18-194.32.1.el5.centos.plus )
> I tried with no success ( sound related ) booting all of the following:
> kernel#2.6.18-238.el5
> kernel#2.6.18-238.el5.centos.plus
> kernel#2.6.18-238.1.1.el5
> kernel#2.6.18-238.1.1.el5.centos.plus
> kernel#2.6.18-238.5.1.el5
> kernel#2.6.18-238.5.1.el5.centos.plus
> This is a nonworking scsconfig.log: http://pastebin.com/XW9e72Jj
> The sound is working fine with the following kernels:
> kernel#2.6.18-194.26.1.el5.centos.plus
> kernel#2.6.18-194.32.1.el5.centos.plus
> and all the older
> This is a working scsconfig.log: http://pastebin.com/xqdMra5q
> Centos was installed on this laptop in 2007 and everything worked ok till now.
> Googling around produced some results but none of them have a working solution
> This email is my second email to the list on the same subject. The
> first email is probably stuck in lalaland due to my poor judgment and
> due to the logs attached. Please excuse me if both of them reach you.
> Can anyone suggest a solution or a path to follow ?
Check the order of driver loading. This affected me a few kernels ago. Found that one needs to force the order of driver loading in modprobe.conf HTH
> Thanks in advance,
> Iulian L. Dragomir
> _______________________________________________
> CentOS mailing list
> CentOS at centos.org
> http://lists.centos.org/mailman/listinfo/centos

More information about the CentOS mailing list