[CentOS] new kernel = no working sound

Sun Apr 10 14:35:10 UTC 2011
Iulian L Dragomir <iulianld at gmail.com>

After updating my laptop ( compaq 6820s) to Centos 5.6 the sound is gone.

The sound card is still detected but there is no sound from speaker

Vendor: Intel Corporation
Model: 82810H (ICH8 Family) HD Audio Controller
Module: snd-hda-intel

On the same updated laptop the sound is working fine with an older
kernel ( 2.6.18-194.32.1.el5.centos.plus )

I tried with no success ( sound related ) booting all of the following:


This is a nonworking scsconfig.log: http://pastebin.com/XW9e72Jj

The sound is working fine with the following kernels:
and all the older

This is a working scsconfig.log: http://pastebin.com/xqdMra5q

Centos was installed on this laptop in 2007 and everything worked ok till now.

Googling around produced some results but none of them have a working solution

This email is my second email to the list on the same subject. The
first email is probably stuck in lalaland due to my poor judgment and
due to the logs attached. Please excuse me if both of them reach you.

Can anyone suggest a solution or a path to follow ?

Thanks in advance,
Iulian L. Dragomir