[CentOS] virtmanager and selinux -- solved

Tue Apr 12 23:31:02 UTC 2011
Negative <negativebinomial at gmail.com>

On Tue, Apr 12, 2011 at 7:17 PM, Negative <negativebinomial at gmail.com>wrote:

> I built a new VM under KVM today and I've been getting  a slew of message
> that selinux is blocking virtmanager from reading the new image. This
> doesn't seem to be doing any harm, but I wanted to check whether I should
> simply run chcon on the image (if I can).
> Virtmanager show up as usr_t, as do my other vm images, but the new one is
> svirt_image_t.
> The selinux error says it denied a read access to virtmanager but that it
> is not expected that the access is required.
> I tried running restorecon as root, as suggested by the selinux error, but
> I'm getting a permission-denied error there. (It tries to set the context to
> usr_t)
> Thanks in advance
My bad. I had to shut down the vm and quit virtmanager before I could run
chcon. It's ok now.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.centos.org/pipermail/centos/attachments/20110412/718593cc/attachment-0002.html>