[CentOS] iscsi multipath fails

Thu Apr 21 20:28:05 UTC 2011
Adam Wead <amsterdamos at gmail.com>

Hi all,

I have a Dell server running cent 5.6, new install, connecting to an IBM
DS3500.  I have configured iscsi connections using iscsid and can log into
the targets on the IBM.  I can also mount the LUNs when accessing them from
their active controller path.  When I throw multipath into the mix, it fails
completely.  Multipath is working, when I run multipath -ll it shows me the
correct active path and it is mapped to a device under /dev/mapper.
However, if I try to access the device from that path, no luck.  A mount
request just hangs and eventually there's a kernel error message.

I'm using the native rdac drivers that came with the OS.  Anyone using
something similar?  My guess is that it's either bad drivers, or a bad
multipath config.  I started with the default, but after tweaking different
parameters, it's still not working.

Any advice is greatly appreciated.


Adam Wead
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.centos.org/pipermail/centos/attachments/20110421/6fe2c316/attachment-0002.html>