[CentOS] OT Problem seeing slave drives.

Tue Apr 5 19:14:49 UTC 2011
John R Pierce <pierce at hogranch.com>

On 04/05/11 11:37 AM, Jimmy Bradley wrote:
>       This isn't specifically about cent os, but I am running cent os on
> this machine. I've got a Dell Dimension 2400 desktop pc. I've tried on a
> number of occasions to put a second hard drive in the machine, but I
> can't get the machine to recognize the second drive in BIOS. I'm going
> to try and keep this short and sweet. I've tried all that I know to try.
> I've set the jumpers on the drives to master and slave, I've tried
> setting the jumpers to cable select. I've changed the IDE ribbon cable.
> As far as I know, I've done all the trouble shooting steps that you'd do
> when having this problem.

(Googles a bit) Ok, thats a Intel 845GV chipset[1], which supports 
UDMA100[2], so you must use 80 wire UDMA style IDE cables or get very 
unreliable results.

wow, thats some old chit.

With UDMA cables, they must be plugged in the correct way, the blue 
connector goes to the mainboard, the far end black connector goes to the 
'master' (1st) drive, and the middle gray connector goes to the slave 
(2nd) drive.  The drives should be jumpered as 'cable select' (but you 
/can/ use master/slave jumpering as LONG as they are connected in the 
correct order).    The connectors should all be 'keyed' by a rectangular 
block molded on one side such that you can't plug them in the wrong way. 
   There also should be a missing pin on the mobo and drives and a 
blocked pin on the cable that acts as a key.   Both devices on the cable 
should be UDMA 100 capable, mixing older technology DMA33 stuff was bad 
news and resulted in all kinda funky behavior.

phew, [1] indicates that system has 2 dimm slots with support for 256M 
and 512M dimms (DDR SDRAM), onboard shared memory graphics, and only has 
one internal drive bay, and a 200 or 230W PSU.   Pentium-4 w/ 400 or 
533Mhz FSB so its probably Northwood generation, circa 2002.    The CMOS 
battery is likely a ball of toxic green fuzz right now.   Frankly, 
anything that old, when it starts misbehaving, its time for the recycle bin.

[1] http://support.dell.com/support/edocs/systems/dim2400/en/sm_en/specs.htm

[2] page 28 
         [different board, but same chips and better documentation]