[CentOS] CentOS-5.5 Live CD & netinstall

Fri Apr 8 00:54:39 UTC 2011
Les Mikesell <lesmikesell at gmail.com>

On 4/7/11 7:28 PM, Timothy Murphy wrote:
> Les Mikesell wrote:
>>>> I assume that the lack of a CD drive on the HP micro-server
>>>> is a sign of things to come,
>>>> so I would hope there would be an official method of installing CentOS
>>>> on such a machine.
>>> I think what Les suggested is one official supported method as outlined
>>> in the Installation Guide. How "official" do you want it ?
>> Here's the prompt you'll see and what it means:
>> http://docs.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/5/html-
> single/Installation_Guide/index.html#s1-begininstall-nfs-x86
> I see no mention there of the method you suggested, which was
> ---------------------------
> I don't get it.
> That's the whole point of the boot.img,
> which is made to simply dd onto a usb device.
> And having booted from that, there is nothing different
> than any other way of booting into the installer
> except that you have to tell it where the install media is.
> ---------------------------
> Actually, I can't find "boot.img" on the DVD:
> [tim at helen ~]$ cd /mnt/dvd
> [tim at helen dvd]$ sudo find . -name disk.img -print
> [tim at helen dvd]$
> I see images/bootdisk.img .
> Is that what you meant?

Yes, my memory isn't that great, but it is in the install guide:

> In any case, I tried dd-ing this to /dev/sdb (the USB stick).
> [tim at helen dvd]$ sudo cp images/diskboot.img /tmp
> [tim at helen dvd]$ cd /tmp
> [tim at helen tmp]$ sudo dd if=diskboot.img of=/dev/sdb
> 24576+0 records in
> 24576+0 records out
> 12582912 bytes (13 MB) copied, 0.766341 seconds, 16.4 MB/s
> But when I re-booted my laptop with the USB stick in
> (having made sure it was top of the boot order in the Bios)
> it failed to start.
> I re-formatted the USB stick under Windows,
> and tried dd-ing diskboot.img to /dev/sdb1
> but the outcome was the same.

It should go to the raw disk device, not a partition and you shouldn't need to 
format first.   I can't help much with this part since I normally boot a CD with 
'linux askmethod' at the prompt to get to that point.  I guess you could try 
grabbing a different copy from a mirror site like:

   Les Mikesell
    lesmikesell at gmail.com