[CentOS] CentOS-5.5 Live CD & netinstall

Fri Apr 8 10:28:26 UTC 2011
Timothy Murphy <gayleard at eircom.net>

Les Mikesell wrote:

>> I tried dd-ing this to /dev/sdb (the USB stick).
>> [tim at helen dvd]$ sudo cp images/diskboot.img /tmp
>> [tim at helen dvd]$ cd /tmp
>> [tim at helen tmp]$ sudo dd if=diskboot.img of=/dev/sdb
>> 24576+0 records in
>> 24576+0 records out
>> 12582912 bytes (13 MB) copied, 0.766341 seconds, 16.4 MB/s
>> But when I re-booted my laptop with the USB stick in
>> (having made sure it was top of the boot order in the Bios)
>> it failed to start.
>> I re-formatted the USB stick under Windows,
>> and tried dd-ing diskboot.img to /dev/sdb1
>> but the outcome was the same.
> It should go to the raw disk device, not a partition and you shouldn't
> need to
> format first. 

The reason I re-formatted it was that fdisk said 
there was no valid partition table after dd-ing bootdisk.img onto /dev/sdb .

> I guess you could
> try grabbing a different copy from a mirror site like:
> http://centos.cs.wisc.edu/pub/mirrors/linux/centos/5.5/os/i386/images/

I'll try again, now that I'm sure what you mean.

Incidentally, I also tried
  livecd-iso-to-disk boot.iso /dev/sdb1
but on re-booting there was just a ";" on my laptop screen.
(The BIOS was set to use the USB stick,
and in fact started fine with CentOS Live USB and Fedora Live USB.)

Timothy Murphy  
e-mail: gayleard /at/ eircom.net
tel: +353-86-2336090, +353-1-2842366
s-mail: School of Mathematics, Trinity College, Dublin 2, Ireland